re = /Country:[\s]+(\S{2})/i
str = 'City: Redmond
StateProv: WA
PostalCode: 98052
Country: US'
# Print the match result
str.match(re) do |match|
puts match.to_s
end