package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+[-–](?:\d+|\(\d+([+\-*/^]\d+[ ]?[+\-*/^][ ]?\d+)?\)))`)
var str = `(0–(2^63 - 1))
(1-(2^16 - 2))
(1-29999984)
(3-32)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}