import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+[-–](?:\\d+|\\(\\d+([+\\-*/^]\\d+[ ]?[+\\-*/^][ ]?\\d+)?\\)))";
final String string = "(0–(2^63 - 1))\n"
+ "(1-(2^16 - 2))\n"
+ "(1-29999984)\n"
+ "(3-32)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}