$re = '`(\d+[-–](?:\d+|\(\d+([+\-*/^]\d+[ ]?[+\-*/^][ ]?\d+)?\)))`';
$str = '(0–(2^63 - 1))
(1-(2^16 - 2))
(1-29999984)
(3-32)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);