re = /(\d+[-–](?:\d+|\(\d+([+\-*\/^]\d+[ ]?[+\-*\/^][ ]?\d+)?\)))/
str = '(0–(2^63 - 1))
(1-(2^16 - 2))
(1-29999984)
(3-32)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end