#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*) \("
Local $sString = "Artist - Title (12") (Warner Bros - WB1210)" & @CRLF & _
"Artist - Title (12", Promo) (Warner Bros - WB1212)" & @CRLF & _
"Artist - Title (Summer Mix) (12", Promo) (Warner Bros - WB1444)" & @CRLF & _
"Artist - Title (12", LP Album) (Warner Bros- - WB9449)" & @CRLF & _
"Artist - Title (12", Red) (Warner Bros - WB1211)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")