// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*) \(").unwrap();
let string = "Artist - Title (12\") (Warner Bros - WB1210)
Artist - Title (12\", Promo) (Warner Bros - WB1212)
Artist - Title (Summer Mix) (12\", Promo) (Warner Bros - WB1444)
Artist - Title (12\", LP Album) (Warner Bros- - WB9449)
Artist - Title (12\", Red) (Warner Bros - WB1211)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}