using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*) \(";
string input = @"Artist - Title (12"") (Warner Bros - WB1210)
Artist - Title (12"", Promo) (Warner Bros - WB1212)
Artist - Title (Summer Mix) (12"", Promo) (Warner Bros - WB1444)
Artist - Title (12"", LP Album) (Warner Bros- - WB9449)
Artist - Title (12"", Red) (Warner Bros - WB1211)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}