#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "href="(?!\.\.\/media)"
Local $sString = "some text <a href="../media/image/aaa.html">aaa</a> some text" & @CRLF & _
"some text <a href="aaa.html">aaa</a> some text" & @CRLF & _
"some text <a href="bbb.html">aaa</a> some text" & @CRLF & _
"some text <a href="../media/ccc.html">aaa</a> some text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")