using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""(?!\.\.\/media)";
string input = @"some text <a href=""../media/image/aaa.html"">aaa</a> some text
some text <a href=""aaa.html"">aaa</a> some text
some text <a href=""bbb.html"">aaa</a> some text
some text <a href=""../media/ccc.html"">aaa</a> some text";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}