use strict;
my $str = 'some text <a href="../media/image/aaa.html">aaa</a> some text
some text <a href="aaa.html">aaa</a> some text
some text <a href="bbb.html">aaa</a> some text
some text <a href="../media/ccc.html">aaa</a> some text';
my $regex = qr/href="(?!\.\.\/media)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}