$re = '/href="(?!\.\.\/media)/';
$str = 'some text <a href="../media/image/aaa.html">aaa</a> some text
some text <a href="aaa.html">aaa</a> some text
some text <a href="bbb.html">aaa</a> some text
some text <a href="../media/ccc.html">aaa</a> some text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);