import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s?[a-zA-Z0-9]+(?:([/:_-])[a-zA-Z0-9]+(?:\\1[a-zA-Z0-9]+)*)?\\s*$";
final String string = "aaa:bbb:cccbbbbb:ssdsfdfd\n"
+ "aaa/bbb/ccc\n"
+ " aa-bb\n"
+ " dd \n\n"
+ "aa0000.\n\n\n"
+ "aaa_bbb:ccc\n"
+ "aaa:bbb\\cccc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}