const regex = new RegExp('^\\s?[a-zA-Z0-9]+(?:([/:_-])[a-zA-Z0-9]+(?:\\1[a-zA-Z0-9]+)*)?\\s*$', 'gm')
const str = `aaa:bbb:cccbbbbb:ssdsfdfd
aaa/bbb/ccc
aa-bb
dd
aa0000.
aaa_bbb:ccc
aaa:bbb\\cccc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}