re = /^\s?[a-zA-Z0-9]+(?:([\/:_-])[a-zA-Z0-9]+(?:\1[a-zA-Z0-9]+)*)?\s*$/m
str = 'aaa:bbb:cccbbbbb:ssdsfdfd
aaa/bbb/ccc
aa-bb
dd
aa0000.
aaa_bbb:ccc
aaa:bbb\\cccc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end