$re = '~^\s?[a-zA-Z0-9]+(?:([/:_-])[a-zA-Z0-9]+(?:\1[a-zA-Z0-9]+)*)?\s*$~m';
$str = 'aaa:bbb:cccbbbbb:ssdsfdfd
aaa/bbb/ccc
aa-bb
dd
aa0000.
aaa_bbb:ccc
aaa:bbb\\cccc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);