use strict;
my $str = '// SHOULD MATCH
array(
\'example\',
\'example\'
);
// NOPE
array(
\'example\',
\'example\',
);
// NOPE
myFucntion(\'test\', \'test\');
// SHOULD MATCH
array(
\'example\',
\'example\'
);
// NOPE
array(
\'example\',
\'example\',
);
// SHOULD MATCH
->setSomething(array(
\'example\',
\'example\'
));
// SHOULD MATCH
->setSomething(array(
new Test,
\'example\'
));
// SHOULD MATCH
->setSomething(array
\'example\',
new Test
));
';
my $regex = qr/array\([^\)]*\'\s*\);/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}