re = /array\([^\)]*\'\s*\);/
str = '// SHOULD MATCH
array(
\'example\',
\'example\'
);
// NOPE
array(
\'example\',
\'example\',
);
// NOPE
myFucntion(\'test\', \'test\');
// SHOULD MATCH
array(
\'example\',
\'example\'
);
// NOPE
array(
\'example\',
\'example\',
);
// SHOULD MATCH
->setSomething(array(
\'example\',
\'example\'
));
// SHOULD MATCH
->setSomething(array(
new Test,
\'example\'
));
// SHOULD MATCH
->setSomething(array
\'example\',
new Test
));
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end