// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)array\([^\)]*\'\s*\);").unwrap();
let string = "// SHOULD MATCH
array(
'example',
'example'
);
// NOPE
array(
'example',
'example',
);
// NOPE
myFucntion('test', 'test');
// SHOULD MATCH
array(
'example',
'example'
);
// NOPE
array(
'example',
'example',
);
// SHOULD MATCH
->setSomething(array(
'example',
'example'
));
// SHOULD MATCH
->setSomething(array(
new Test,
'example'
));
// SHOULD MATCH
->setSomething(array
'example',
new Test
));
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}