$re = '/array\([^\)]*\'\s*\);/s';
$str = '// SHOULD MATCH
array(
\'example\',
\'example\'
);
// NOPE
array(
\'example\',
\'example\',
);
// NOPE
myFucntion(\'test\', \'test\');
// SHOULD MATCH
array(
\'example\',
\'example\'
);
// NOPE
array(
\'example\',
\'example\',
);
// SHOULD MATCH
->setSomething(array(
\'example\',
\'example\'
));
// SHOULD MATCH
->setSomething(array(
new Test,
\'example\'
));
// SHOULD MATCH
->setSomething(array
\'example\',
new Test
));
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);