#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sx)(?<=/)\d+"
Local $sString = "https://www.flickr.com/photos/sdasmarchives/8004393890/in/photolist-dcjBrd-qJX244-cnT1Um-bUBvH1-avgira-dcjERJ-8bjWSe-r4UAfF-7h1iuk-SXsidX-bF9Auf-pvnyFe-dcjADK-dV8DPd-dKcBhS-qvJWV3-cnkfdS-pMX4Ym-dcjBji-dV3a4L-dcjByA-dcjykA-8bohud-cnT1ry-cS8CpN-7v1YJ3-qeov7k-bbpFBX-7ZAkCX-dF1y7D-hHPnWc-e8QdTV-6fMZTv-7ZAkDF-6K4JrR-hkHtCY-aWjBu6-5QuCU2-dcjETE-8izDu5-dhZFgR-rmk5oB-TjSLSy-6HAhJL-f7X3AF-TZGwG1-bUwueL-evVBry-dgDH5e-dcjxsT/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")