import Foundation
let pattern = #"(?<=/)\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = #"https://www.flickr.com/photos/sdasmarchives/8004393890/in/photolist-dcjBrd-qJX244-cnT1Um-bUBvH1-avgira-dcjERJ-8bjWSe-r4UAfF-7h1iuk-SXsidX-bF9Auf-pvnyFe-dcjADK-dV8DPd-dKcBhS-qvJWV3-cnkfdS-pMX4Ym-dcjBji-dV3a4L-dcjByA-dcjykA-8bohud-cnT1ry-cS8CpN-7v1YJ3-qeov7k-bbpFBX-7ZAkCX-dF1y7D-hHPnWc-e8QdTV-6fMZTv-7ZAkDF-6K4JrR-hkHtCY-aWjBu6-5QuCU2-dcjETE-8izDu5-dhZFgR-rmk5oB-TjSLSy-6HAhJL-f7X3AF-TZGwG1-bUwueL-evVBry-dgDH5e-dcjxsT/"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)