const regex = new RegExp('(?<=/)\\d+', 'gs')
const str = `https://www.flickr.com/photos/sdasmarchives/8004393890/in/photolist-dcjBrd-qJX244-cnT1Um-bUBvH1-avgira-dcjERJ-8bjWSe-r4UAfF-7h1iuk-SXsidX-bF9Auf-pvnyFe-dcjADK-dV8DPd-dKcBhS-qvJWV3-cnkfdS-pMX4Ym-dcjBji-dV3a4L-dcjByA-dcjykA-8bohud-cnT1ry-cS8CpN-7v1YJ3-qeov7k-bbpFBX-7ZAkCX-dF1y7D-hHPnWc-e8QdTV-6fMZTv-7ZAkDF-6K4JrR-hkHtCY-aWjBu6-5QuCU2-dcjETE-8izDu5-dhZFgR-rmk5oB-TjSLSy-6HAhJL-f7X3AF-TZGwG1-bUwueL-evVBry-dgDH5e-dcjxsT/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}