import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=/)\\d+";
final String string = "https://www.flickr.com/photos/sdasmarchives/8004393890/in/photolist-dcjBrd-qJX244-cnT1Um-bUBvH1-avgira-dcjERJ-8bjWSe-r4UAfF-7h1iuk-SXsidX-bF9Auf-pvnyFe-dcjADK-dV8DPd-dKcBhS-qvJWV3-cnkfdS-pMX4Ym-dcjBji-dV3a4L-dcjByA-dcjykA-8bohud-cnT1ry-cS8CpN-7v1YJ3-qeov7k-bbpFBX-7ZAkCX-dF1y7D-hHPnWc-e8QdTV-6fMZTv-7ZAkDF-6K4JrR-hkHtCY-aWjBu6-5QuCU2-dcjETE-8izDu5-dhZFgR-rmk5oB-TjSLSy-6HAhJL-f7X3AF-TZGwG1-bUwueL-evVBry-dgDH5e-dcjxsT/";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}