#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*)$[\r\n]{1,*}^$[\r\n]{1,2}^(.*)$"
Local $sString = "foo" & @CRLF & _
"" & @CRLF & _
"bar" & @CRLF & _
"" & @CRLF & _
"sd" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")