const regex = /(?m)^(.*)$[\r\n]{1,*}^$[\r\n]{1,2}^(.*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^(.*)$[\\r\\n]{1,*}^$[\\r\\n]{1,2}^(.*)$', '')
const str = `foo
bar
sd
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}