using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(.*)$[\r\n]{1,*}^$[\r\n]{1,2}^(.*)$";
string input = @"foo
bar
sd
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}