$re = '/(?m)^(.*)$[\r\n]{1,*}^$[\r\n]{1,2}^(.*)$/';
$str = 'foo
bar
sd
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);