import re
regex = re.compile(r".+?\/([^\/]+?(?=\)).+)$", flags=re.MULTILINE)
test_str = ("url(../img/repeat-elements/tpl-action-section_bg-1200.png) no-repeat 50%/1200px;\n"
"url(../img/pages/home/what-is_bg-1400.png) no-repeat 100% 50%/500px;\n"
"url(../img/blog/action/action_1-1400.png) no-repeat 100% 50%/500px;")
subst = "ВАЛЕНОК$1"
result = regex.sub(subst, test_str)
if result:
print(result)