using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^,]*(движение)+[^,]*";
string input = @"Создание сайтов,Разработка сайтов,Диза йн сайтов,Продвижение сайтов,Раскрутка сайтов,SEO продвижение сайтов,Поддержка сайтов";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}