$re = '/[^,]*(движение)+[^,]*/m';
$str = 'Создание сайтов,Разработка сайтов,Дизайн сайтов,Продвижение сайтов,Раскрутка сайтов,SEO продвижение сайтов,Поддержка са йтов';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);