package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^,]*(движение)+[^,]*`)
var str = `Создание сайтов,Разработка сайтов,Дизайн сайтов,Продвижение сайтов,Раскрутка сайтов,SEO продвижение сайтов,Поддержка сайтов`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}