re = /[^,]*(движение)+[^,]*/m
str = 'Создание сайтов,Разработка сайтов,Дизайн сайтов,Продвижение сайтов,Раскрутка сайтов,SEO продвижение сайтов,Поддержка сайтов'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end