const regex = /^(\w+): (.*)\n((?:(?!\1).*\n)+)\1: (.*\n)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+): (.*)\\n((?:(?!\\1).*\\n)+)\\1: (.*\\n)', 'gm')
const str = `abc: bla1 bla1 bla1...
cde: bla bla bla...
ghk: bla1 bla1 bla1...
lmn: bla bla bla...
abc: bla2 bla2 bla2...
bcd: bla bla bla...
ghk: bla2 bla2 bla2...
xyz: bla bla bla...`;
const subst = `\1: \2 \4\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);