import Foundation
let pattern = #"^(\w+): (.*)\n((?:(?!\1).*\n)+)\1: (.*\n)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abc: bla1 bla1 bla1...
cde: bla bla bla...
ghk: bla1 bla1 bla1...
lmn: bla bla bla...
abc: bla2 bla2 bla2...
bcd: bla bla bla...
ghk: bla2 bla2 bla2...
xyz: bla bla bla...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1: \2 \4\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)