use strict;
my $str = 'abc: bla1 bla1 bla1...
cde: bla bla bla...
ghk: bla1 bla1 bla1...
lmn: bla bla bla...
abc: bla2 bla2 bla2...
bcd: bla bla bla...
ghk: bla2 bla2 bla2...
xyz: bla bla bla...';
my $regex = qr/^(\w+): (.*)\n((?:(?!\1).*\n)+)\1: (.*\n)/mp;
my $subst = '\\1: \\2 \\4\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";