using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<\/h\d+>\s*)\S.*?(?=\s*<h\d|$)";
string input = @"<h2>What is lorem impsum</h2>
Stack overflow is a great community for developers to seek help and connect the beautiful experience.
<h3>What is quora?</h3>
Quoora is good but doesn\'t provide any benefits to the person who\'s helping others economically.
But its a nice place to be at.
another paragraph betwen these headings
<h3>Who is Kent C Dodds</h3>
One of the best guy to learn react with. He also has helped a lot of
people with his kindness and his contents on the internet.";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}