const regex = /(?<=<\/h\d+>\s*)\S.*?(?=\s*<h\d|$)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<\\\/h\\d+>\\s*)\\S.*?(?=\\s*<h\\d|$)', 'gs')
const str = `<h2>What is lorem impsum</h2>
Stack overflow is a great community for developers to seek help and connect the beautiful experience.
<h3>What is quora?</h3>
Quoora is good but doesn\\'t provide any benefits to the person who\\'s helping others economically.
But its a nice place to be at.
another paragraph betwen these headings
<h3>Who is Kent C Dodds</h3>
One of the best guy to learn react with. He also has helped a lot of
people with his kindness and his contents on the internet.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}