import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<\\/h\\d+>\\s*)\\S.*?(?=\\s*<h\\d|$)";
final String string = "<h2>What is lorem impsum</h2>\n"
+ "Stack overflow is a great community for developers to seek help and connect the beautiful experience.\n\n"
+ "<h3>What is quora?</h3>\n"
+ "Quoora is good but doesn\\'t provide any benefits to the person who\\'s helping others economically. \n"
+ "But its a nice place to be at.\n"
+ "another paragraph betwen these headings\n\n"
+ "<h3>Who is Kent C Dodds</h3>\n"
+ "One of the best guy to learn react with. He also has helped a lot of \n"
+ "people with his kindness and his contents on the internet.";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}