use strict;
my $str = '<h2>What is lorem impsum</h2>
Stack overflow is a great community for developers to seek help and connect the beautiful experience.
<h3>What is quora?</h3>
Quoora is good but doesn\\\'t provide any benefits to the person who\\\'s helping others economically.
But its a nice place to be at.
another paragraph betwen these headings
<h3>Who is Kent C Dodds</h3>
One of the best guy to learn react with. He also has helped a lot of
people with his kindness and his contents on the internet.';
my $regex = qr/(?<=<\/h\d+>\s*)\S.*?(?=\s*<h\d|$)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}