import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:0[1-9]|[12]\\d|3[01])(?=\\.(?:0[13578]|1[02]))|(?:0[1-9]|[12]\\d|30)(?=\\.(?:0[469]|11))|(?:0[1-9]|1\\d|2[0-9])(?=\\.02))\\.(\\d{2})\\.(\\d{4,})";
final String string = "30.10.2016\n"
+ "29.02.2016\n"
+ "29.02.2015\n"
+ "29.02.2014\n"
+ "29.02.2013\n"
+ "29.02.2012\n"
+ "30.09.2016\n"
+ "31.09.2016\n"
+ "31.01.2016";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}