import re
regex = re.compile(r"((?:0[1-9]|[12]\d|3[01])(?=\.(?:0[13578]|1[02]))|(?:0[1-9]|[12]\d|30)(?=\.(?:0[469]|11))|(?:0[1-9]|1\d|2[0-9])(?=\.02))\.(\d{2})\.(\d{4,})", flags=re.MULTILINE)
test_str = ("30.10.2016\n"
"29.02.2016\n"
"29.02.2015\n"
"29.02.2014\n"
"29.02.2013\n"
"29.02.2012\n"
"30.09.2016\n"
"31.09.2016\n"
"31.01.2016")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")