const regex = /((?:0[1-9]|[12]\d|3[01])(?=\.(?:0[13578]|1[02]))|(?:0[1-9]|[12]\d|30)(?=\.(?:0[469]|11))|(?:0[1-9]|1\d|2[0-9])(?=\.02))\.(\d{2})\.(\d{4,})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:0[1-9]|[12]\\d|3[01])(?=\\.(?:0[13578]|1[02]))|(?:0[1-9]|[12]\\d|30)(?=\\.(?:0[469]|11))|(?:0[1-9]|1\\d|2[0-9])(?=\\.02))\\.(\\d{2})\\.(\\d{4,})', 'gm')
const str = `30.10.2016
29.02.2016
29.02.2015
29.02.2014
29.02.2013
29.02.2012
30.09.2016
31.09.2016
31.01.2016`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}