re = /((?:0[1-9]|[12]\d|3[01])(?=\.(?:0[13578]|1[02]))|(?:0[1-9]|[12]\d|30)(?=\.(?:0[469]|11))|(?:0[1-9]|1\d|2[0-9])(?=\.02))\.(\d{2})\.(\d{4,})/m
str = '30.10.2016
29.02.2016
29.02.2015
29.02.2014
29.02.2013
29.02.2012
30.09.2016
31.09.2016
31.01.2016'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end