use strict;
my $str = '{"action":"add","actions":[{"country","IND"}],"ctx":"{\\"charset\\":\\"UTF-8\\",\\"client_id\\":\\"G9.2.2045341156.1629864410\\",\\"cookie\\":\\"1\\",\\"domain_user\\":\\"28f51979-bef8-4731-b242-e3a00496d9ba\\",\\"fp\\":\\"659810303\\",\\"id\\":\\"d368f505-6226-4650-aeba-caf9fb18fc53\\",\\"page_res\\":\\"478x4952\\",\\"refr\\"
Sample records';
my $regex = qr/(\[\{[^\{\[\]\}]*)(\",\")([^\[\]\{\}]*\}\])/mp;
my $subst = '\\1\\\\\\",\\\\\\"\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";