# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\[\{[^\{\[\]\}]*)(\",\")([^\[\]\{\}]*\}\])"
test_str = ("{\"action\":\"add\",\"actions\":[{\"country\",\"IND\"}],\"ctx\":\"{\\\"charset\\\":\\\"UTF-8\\\",\\\"client_id\\\":\\\"G9.2.2045341156.1629864410\\\",\\\"cookie\\\":\\\"1\\\",\\\"domain_user\\\":\\\"28f51979-bef8-4731-b242-e3a00496d9ba\\\",\\\"fp\\\":\\\"659810303\\\",\\\"id\\\":\\\"d368f505-6226-4650-aeba-caf9fb18fc53\\\",\\\"page_res\\\":\\\"478x4952\\\",\\\"refr\\\"\n"
"Sample records")
subst = "\\1\\\\\\\",\\\\\\\"\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.