package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[([^\[\]]+)\]`)
var str = `zp_fr_m3g_sma_redi_redxred_MB:[[1214920][][ultramarine-duck][kilo-vau-36YorIEp][-_-16]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}