re = /\[([^\[\]]+)\]/
str = 'zp_fr_m3g_sma_redi_redxred_MB:[[1214920][][ultramarine-duck][kilo-vau-36YorIEp][-_-16]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end