// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[([^\[\]]+)\]").unwrap();
let string = "zp_fr_m3g_sma_redi_redxred_MB:[[1214920][][ultramarine-duck][kilo-vau-36YorIEp][-_-16]]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}