const regex = new RegExp('\\[([^\\[\\]]+)\\]', 'g')
const str = `zp_fr_m3g_sma_redi_redxred_MB:[[1214920][][ultramarine-duck][kilo-vau-36YorIEp][-_-16]]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}